Login

Navigation

This articles is published 129 days ago and last updated 129 days ago, some information may be out of date.

Cisco DHCP Relay Agent (IP Helper)基本設定

2021-09-20_150734_Cover.png

前言:
所有的練習是基於「Cisco Packet Tracer」軟件平台。
原理:
DHCP Relay Agent 是客戶端和DHCP伺服器之間的橋樑,透過DHCP Relay Agent可以在不同的網段間接收客戶端的廣播,從而DHCP伺服器可以順利派送IP地址到客戶端。
目標:
在路由器的單網口上配置多組vlan,在不同的vlan間透過DHCP伺服器派送IP地址。

2021-09-20_150745.png

vLanIP(Subnet)
vlan10192.168.10.0/24
vlan20192.168.20.0/24
vlan30192.168.30.0/24
vlan40192.168.40.0/24
PC1在vlan10

PC2在vlan20

PC3在vlan30

PC0在vlan40

DHCP Server (192.168.40.254)在vlan40,所有的vlan(10、20、30、40)的客戶端電腦可經vlan40的DHCP Server獲派IP地址 。

DHCP伺服器設定

2021-09-20_150603.png

指定IP地址為 192.168.40.254

2021-09-20_150616.png

建立4組DHCP地址分配池分別對應Vlan 10、Vlan 20、Vlan 30、Vlan 40

路由器的設置(Cisco 2911)

2021-09-20_142815.png

Router>enable
Router#configure terminal
進入Global Configuration Mode模式
Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit
選物理取網口0/0,并啟用
Router(config)#interface gigabitEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit
在物理網口0/0上配置子網口

配置802.1Q協定,并劃分vlan10

設定網口IP地址 ip address 192.168.10.1 255.255.255.0

Router(config)#interface gigabitEthernet 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#end
在物理網口0/0上配置子網口

配置802.1Q協定,并劃分vlan20

設定網口IP地址 ip address 192.168.20.1 255.255.255.0

Router(config)#interface gigabitEthernet 0/0.30
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#end
在物理網口0/0上配置子網口

配置802.1Q協定,并劃分vlan30

設定網口IP地址 ip address 192.168.30.1 255.255.255.0

Router(config)#interface gigabitEthernet 0/0.40
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.40.1 255.255.255.0
Router(config-subif)#end
在物理網口0/0上配置子網口

配置802.1Q協定,并劃分vlan40

設定網口IP地址 ip address 192.168.40.1 255.255.255.0

Router#write
存檔
路由器的DHCP Relay Agent設置

2021-09-20_144133.png

Router>enable
Router#configure terminal
進入Global Configuration Mode模式
Router(config)#interface gigabitEthernet 0/0.10
Router(dhcp-config)#ip helper-address 192.168.40.254
Router(dhcp-config)#exit
指定vlan10的DHCP Relay Agent為DHCP 伺服器IP地址
Router(config)#interface gigabitEthernet 0/0.20
Router(dhcp-config)#ip helper-address 192.168.40.254
Router(dhcp-config)#exit
指定vlan20的DHCP Relay Agent為DHCP 伺服器IP地址
Router(config)#interface gigabitEthernet 0/0.30
Router(dhcp-config)#ip helper-address 192.168.40.254
Router(dhcp-config)#exit
指定vlan30的DHCP Relay Agent為DHCP 伺服器IP地址

*因為DHCP 伺服器在vlan 40,所以 vlan40不用設定DHCP Relay Agent

Router(dhcp-config)#end
Router#write
存檔
交換機的設置(Cisco 2960-24T)

Switch1

2021-09-20_143633.png

Switch>enable
Switch#configure terminal
進入Global Configuration Mode模式
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#vlan 30
Switch(config-vlan)#vlan 40
Switch(config-vlan)#exit
建立4組vlan
Switch(config)#interface range gigabitEthernet 0/1-2
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#exit
劃分網口g0/1,g0/2為Trunk模式 (*所有vlan數據經這接口傳送到客戶端裝置)
Switch(config)#interface range fastEthernet 0/1-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
劃分網口f0/1-10給Vlan10
Switch(config)#interface range fastEthernet 0/11-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#end
劃分網口f0/11-20給Vlan20
Switch#write
存檔

Switch2

2021-09-20_143942.png

Switch>enable
Switch#configure terminal
進入Global Configuration Mode模式
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#vlan 30
Switch(config-vlan)#vlan 40
Switch(config-vlan)#exit
建立4組vlan
Switch(config)#interface range gigabitEthernet 0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
劃分網口g0/2為Trunk模式 (*連接Switch1的g0/2網口)
Switch(config)#interface range fastEthernet 0/1-10,f0/24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch(config-if-range)#exit
劃分網口f0/1-10及f0/24給Vlan40
Switch(config)#interface range fastEthernet 0/11-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#end
劃分網口f0/11-20給Vlan30
Switch#write
存檔
電腦獲取IP地址及互通測試

2021-09-20_144411.png

PC1分配到的IP地址為192.168.10.11 (vlan10網段)

2021-09-20_144416.png

PC2分配到的IP地址為192.168.20.10 (vlan20網段)

2021-09-20_144423.png

PC3分配到的IP地址為192.168.30.10 (vlan30網段)

2021-09-20_144433.png

PC0分配到的IP地址為192.168.40.11 (vlan40網段)

2021-09-20_144554.png

PC1 Ping PC2、PC3、PC0 (可以相互通信)